Back to overview
Resolved
Delays on volume provisioning, attach, detach actions
Aug 13, 2026 at 1:16pm UTC
Affected services
Block Storage
Resolved
Aug 13, 2026 at 1:23pm UTC
All systems are operating at normal levels again.
Affected services
Created
Aug 13, 2026 at 1:16pm UTC
We are currently experiencing a large influx of operations on our volume provisioning system. We are investigating.
Users may experience delays with volume provisioning, attaching, detaching or other volume operations. Availability of attached volumes is not impacted.
Affected services